DNS Related errors causing App unavailability
Incident Report for logz.io
Resolved
Akamai have reported that the issue is fully resolved. We have not seen any issues since they started working on the resolution, and all our monitoring indicates that we are fully functional.

Important: If you have implemented our HOSTS Workaround, please remove it in order to fall back on the normal DNS resolution path and continued service.
Posted Jul 22, 2021 - 20:13 IDT
Update
Akamai are reporting that they "have implemented a fix for this issue, and based on current observations, the service is resuming normal operations. We will continue to monitor to ensure that the impact has been fully mitigated."

Once the issue is resolved, if you have implemented our HOSTS Workaround, please remove it in order to fall back on the normal DNS resolution path and continued service.
Posted Jul 22, 2021 - 19:55 IDT
Monitoring
We are seeing multiple indications that the problem on Akamai DNS is resolving, and we are monitoring their recovery.
https://edgedns.status.akamai.com/
Posted Jul 22, 2021 - 19:39 IDT
Update
In order to bypass the DNS issue, you can map the relevant URL directly to the server IP address by editing your OS hosts file*:
195.10.9.163 app-eu.logz.io
23.222.79.168. app.logz.io
23.34.240.162 app-ca.logz.io
23.222.16.82 app-wa.logz.io
96.7.74.51 app-au.logz.io
88.221.222.183 app-uk.logz.io

Location of the hosts file in macOS/linux:
/etc/hosts

Location of the hosts file in Windows:
C:\Windows\System32\drivers\etc
Posted Jul 22, 2021 - 19:34 IDT
Update
Our current findings indicate the DNS issue is Akamai related (not AWS). We are working on providing a workaround.
Posted Jul 22, 2021 - 19:20 IDT
Identified
We have identified the problem is DNS related, and seems to be word-wide, affecting multiple providers in multiple world regions. Akamai and AWS, which are both part of our resolution path are also reporting extensive DNS problems.
Posted Jul 22, 2021 - 19:10 IDT
Update
It seems that shipping is not affected, and there is more evidence that it is a DNS issue, probably related to AWS.
Some of our customers may be experiencing problems connecting to app.logz.io
Posted Jul 22, 2021 - 18:57 IDT
Investigating
We are currently experiencing possible App downtime due to DNS errors. We are investigating the issue with multiple Engineering teams. We will update this incident as we learn new details.
Posted Jul 22, 2021 - 18:46 IDT