Ongoing AWS us-east Outage Impacting Metrics and Logs Ingestion

Incident Report for logz.io

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 23:38 IDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 17:21 IDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 15:44 IDT

Monitoring

We're currently experiencing delays in metrics and logs ingestion due to an AWS outage in the us-east region. Our team is monitoring AWS Health status and will provide updates once the issue is resolved.
We're still working to recover from the AWS outage, and our development team is actively addressing the remaining impact.
Please note that some backfilled metrics and logs may be missing after the outage is resolved, and you may also experience some latency during the recovery process.
Posted Oct 20, 2025 - 10:30 IDT
This incident affected: AWS N. Virginia (us-east-1) (Alerts & Security rules, Logs Ingestion).