A few Accounts in AWS US-East Region are Experiencing Degradation on loading Metrics Tab

Incident Report for logz.io

Resolved

This incident has been resolved.
Posted Sep 03, 2025 - 17:04 IDT

Identified

We are currently investigating an issue affecting the Metrics product for some accounts in the US-East region
Posted Sep 03, 2025 - 13:46 IDT
This incident affected: AWS N. Virginia (us-east-1) (Metrics Visualizations and Dashboards).